Apache + mod_php4 + mod_php5

Teiksiet nau iespējams ? Kļūdīsities 🙂

Zināšu teikt tikai par Gentoo linux distribūciju, ir parādijies jauns USE flags pie dev-lang/php* – “concurrentmodphp” kurš ļauj kompilēt gan php4 gan php5 kā moduļus priekš Apache2, tad katrs mod_php iegūst savus mime-types (application/x-httpd-php4{-source} priekš PHP4 un application/x-httpd-php5{-source} priekš PHP5) un konfigurācijas modifierus (php4_admin_value/php4_admin_flag priekš PHP4 un php5_admin_value/php5_admin_flag priekš PHP5 utt.).

Šī lieta gan esot ļoti eksperimentāla, uz x86 strādājot bez kļūdām, kā arī daļēji uz x86_64.

Ja kāds grib meģināt, neiesakam mēģināt uz production serveriem, bet gan uz test serveriem.

emerge --sync<br /> echo dev-lang/php >> /etc/portage/package.keywords<br /> USE="<a href=http://httpd.apache.org/>Apache</a>2 concurrentmodphp" emerge =php-4* =php-5*

pēc tam neaizmirstam “etc-update” un re-emergot VISUS instaletos PHP moduļus/ekstensijas (piemēram dev-php4/pecl-zip utt.). Kā arī šis nestrādās ar “java-internal” (PHP4) un “sharedext” (PHP4/5) USE flagiem.

informācija no http://chtekk.longitekk.com/

 
comments powered by Disqus